Написать программу при помощи операций div и mod. 1. Задано двузначное число. Найдите...

0 голосов
130 просмотров

Написать программу при помощи операций div и mod. 1. Задано двузначное число. Найдите среднее арифметическое цифр числа.


Информатика (12 баллов) | 130 просмотров
Дано ответов: 2
0 голосов

var  

 a: integer;

 b,c,s: real;

begin

 writeln('Введите число');

 read(a);

 b:=a div 10;

 c:=a mod 10;

 s:=(b+c)/2;

 writeln('Среднее арифметическое: ',s);

end.  

(12.2k баллов)
0 голосов

var a,b,c:integer;

   s:real;

begin

writeln('Введите двузначное число:');

read(a);

b:=a mod 10;

c:=a div 10;

s:=(b+c)/2;

writeln('Среднее арифметическое: ',s);

end.    

(446 баллов)