Напишите программу, которая выведет на экран значение true или false, в зависимости от того, является ли введенное число х четырехзначным или нет.Пожалуйста сделайтеКому надо фото, 5 задание
язык?
var x: integer;a: boolean;beginwriteln('Введите число');read(x);a:=(x>999);writeln('Число четырёхзначное ',a);end.
procedure foo(n: integer; k: integer := 0);
begin
if n = 0 then Print(k = 4)
else foo(n div 10, k + 1)
end;
var N := ReadInteger();
foo(N)
end.
PascalABC.NET