Напишите программу: Заполнить матрицу n x m числами от 1 до n*m. И вывести ее ** экран....

0 голосов
80 просмотров

Напишите программу: Заполнить матрицу n x m числами от 1 до n*m. И вывести ее на экран. Написать на питоне


Информатика (20 баллов) | 80 просмотров
Дан 1 ответ
0 голосов

n, m = int(input()), int(input())

matrix = []

i = 0

for line in range(0, m):

   matrix.append([])

  for item in range(0, n):

       i += 1

       if i > m * n:

           break

       matrix[line].append(i)

           

print(matrix)


(1.7k баллов)