Напишите программу ** языке Паскаль, для решения следующей задачи:Для любого...

0 голосов
36 просмотров

Напишите программу на языке Паскаль, для решения следующей задачи:
Для любого четырехзначного вводимого числа найти сумму второй и предпоследней цифры).
(Подсказка. Используйте тип данных integer и операции div и mod)


Информатика (54 баллов) | 36 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a,b,c,d:integer;
begin
readln(a);
b:=(a div 100)mod 10;
c:=(a mod 100)div 10;
d:=b+c;
writeln(d);
readln;
end.

(648 баллов)
0

пойдет ?

0

или пользовательский интерфейс добавить ?

0 голосов

Var a,b,c:integer;
begin
read (c);
a:=c div 100;  a:=a mod 10;
b:=c div 10;  b:=b mod 100;
write(a+b);
end.

(2.1k баллов)