Напишите программу вычисления выражения:s=1!+2!+3!+...+n!Здесь n! - факториал числа n....

0 голосов
234 просмотров

Напишите программу вычисления выражения:s=1!+2!+3!+...+n!Здесь n! - факториал числа n. n!=1×2×...×(n-1)× n.Используйте функцию вычисления факториала.СПАСИБО.​


Информатика (20 баллов) | 234 просмотров
Дан 1 ответ
0 голосов

var

   n : integer;

   S : decimal;

   

function fac(n : integer) : decimal;

begin

   result := 1;

   for var i := 1 to n do result := result * i;

end;


begin

   write('введите n = ');

   readln(n);

   for var i := 1 to n do S := S+fac(i);

   writeln('S=', S);

end.

(1.2k баллов)