Напишите программу используя массивы.

0 голосов
13 просмотров

Напишите программу используя массивы.


image

Информатика (82 баллов) | 13 просмотров
Дан 1 ответ
0 голосов

var

   a : integer;

   b : integer;

   

begin

   repeat

       a := random(1, 9);

       repeat

           write('напишите свое число ');

           readln(b);

           if (9 < b) or (b < 1) then writeln('не мухлевать! число должно быть от 1 до 9');

       until (9 >= b) and (b >= 1);

       writeln('ваш друг написал ', a);

       writeln('вы написали ', b);

       if a=b then writeln('числа равны, переиграем...');

   until a <> b;

   case a-b of

       1    : writeln('неудача, ваше число меньше на 1. Вам платить сегодня и завтра');

       -1   : writeln('повезло, вше число больше на 1. Сегодня и завтра платит ваш друг');

       2..8 : writeln('сегодня платит ваш друг, его число больше на ', a-b);

       else writeln('сегодня платите вы, ваше число больше на ', b-a);

   end;

end.

(1.2k баллов)