Помогите пожалуйста решить: напишите программу для решения следующей задачи. Камера...

0 голосов
178 просмотров

Помогите пожалуйста решить: напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км/ч, выведите "YES", иначе выведите "NO".Программа получает на вход число проехавших автомобилей N(1<N<30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести максимальную скорость затем YES или NO.помогите пожалуйста !!!пример вводных данных474696366примеры входных данных74NO​


Информатика (65 баллов) | 178 просмотров
Дан 1 ответ
0 голосов

n = int(input())

max_speed = 0

check = True

for i in range(0, n):

   a = int(round(float(input())))

   if a > max_speed:

       max_speed = a

   if check == True:

       if a < 30:

           check = False

print(max_speed)

if not check:

   print('YES')

else:

   print('NO')

(1.7k баллов)
0

помогите пж