Напишите программу ** PascalABC - дано слово. Переставьте его последнюю букву ** место...

0 голосов
64 просмотров

Напишите программу на PascalABC - дано слово. Переставьте его последнюю букву на место первой. Подразумевается при этом, что все последующие буквы будут сдвинуты вправо на одну позицию. Вводится строка, состоящая из одного слова (последовательность строчных латинских букв без пробелов) длиной не более 150 символов.


Информатика (16 баллов) | 64 просмотров
0

можно просто вывести последнюю и потом всё слово без последней?

0

Переставьте его последнюю букву на место первой

0

henomenonp --- phenomenon

0

без проблем сек

Дан 1 ответ
0 голосов

var

 str:string;

 s:char;

 i:integer;

Begin

 readln(str);

 s := str[length(str)];

 str := str + '0';

 for i := length(str)-1 downto 1 do begin

   str[i+1] := str[i];

 end;

 str[1] := s;

 delete(str, length(str), 1);

 writeln(str);

End.

жду лучший ответ

(195 баллов)
0

можно удалить две строки программы без потери работоспособности:str := str + '0';иdelete(str, length(str), 1);

0

если ты удалишь делет тогда останется последняя буква, а если первую тогда вообще не запустится

0

хотя

0

ща сделаю

0

а стоп, фигню сморозил, да уж

0

я не знаю чем думал

0

var slovo:string; bukwa:char; i:integer;begin readln(slovo); bukwa := slovo[length(slovo)]; for i := length(slovo)-1 downto 1 do slovo[i+1] := slovo[i]; slovo[1] := bukwa; writeln(slovo);end.