50 БАЛЛОВ!PascalABC.NET программа!1)Всем известно, что в неделе 7 дней: понедельник...

0 голосов
64 просмотров

50 БАЛЛОВ!PascalABC.NET программа!1)Всем известно, что в неделе 7 дней: понедельник (Monday), вторник (Tuesday), среда (Wednesday), четверг (Thursday), пятница (Friday), суббота (Saturday) и воскресенье (Sunday).По номеру дня недели следует определить англоязычный вариант его записи.Входные данныеВходной файл INPUT.TXT содержит целое число N – номер дня недели (1 ≤ N ≤ 7).Выходные данныеВ выходной файл OUTPUT.TXT выведите ответ на задачу с заглавной буквы.2) В классе учится X мальчиков и Y девочек. Каждый день, приходя в школу, они здороваются друг с другом. Входя в класс, каждый мальчик жмет руку каждому пришедшему ранее мальчику, а каждой девочке он говорит «Привет!», и каждая девочка отвечает ему «Привет!». С девочками все еще проще: когда в класс заходит девочка, то она говорит «Привет!» каждому мальчику и каждой девочке, а те ей также отвечают «Привет!».Ваша задача – посчитать количество рукопожатий и приветствий.Входные данныеВходной файл INPUT.TXT содержит целые числа X и Y (0 ≤ X, Y ≤ 108).Выходные данныеВ выходной файл OUTPUT.TXT выведите два целых числа через пробел – количество рукопожатий и приветствий соответственно.


Информатика (104 баллов) | 64 просмотров
0

пж

Дан 1 ответ
0 голосов

Номер 1

const

   D: array[1..7] of string = ('Monday', 'Tuesday', 'Wednesday', 'Thursday', 'Friday', 'Saturday', 'Sunday');

var

   day: longint;

begin

   writeln('Введите номер дня.');

   readln(day);

   writeln(D[day]);

end.

(4.1k баллов)