Написать программу, которая выводит целые числа в промежутку от 1 до 50, кратные...

0 голосов
60 просмотров

Написать программу, которая выводит целые числа в промежутку от 1 до 50, кратные двенадцати и считает их количество, сумму и произведение.


Информатика (14 баллов) | 60 просмотров
0

Какой язык?

Дан 1 ответ
0 голосов

var amount, sum, multi, i: integer;

begin

   amount:= 0;

   sum:= 0;

   multi:= 1;

   for i:=1 to 51 do begin

       if i mod 12 = 0 then begin

           writeln(i);

           amount:= amount + 1;

           sum:= sum + i;

           multi:= multi * i;

       end;

   end;

   writeln(amount, ' ', sum, ' ', multi);

end.

##########

amount = 0

sum = 0

multi = 1

for i in range(1, 51):

   if i % 12 == 0:

       print(i)

       amount += 1

       sum += i

       multi *= i

print(amount, ' ', sum, ' ', multi)

(1.7k баллов)
0

Если другой язык, перепишу :3

0

Мне бы на Паскале пжалста (сам не знаю почему с самого начала не написал об этом).

0

щас поменяю

0

добавил в начало