Те кто работает с паскалем, помогите пж. Составьте программу. Пользователь вводит цены 1...

0 голосов
82 просмотров

Те кто работает с паскалем, помогите пж. Составьте программу. Пользователь вводит цены 1 кг конфет и 1 кг печенья. Найдите стоимость: а) одной покупки из 300 г конфет и 400 г печенья; б) трех покупок, каждая из 2 кг печенья и 1 кг 800 г конфет.


Информатика (145 баллов) | 82 просмотров
Дан 1 ответ
0 голосов

var

   cookie, sweets: real;

begin

   writeln('Введите цены 1 кг конфет и 1 кг печенья:');

   readln(sweets, cookie);

   sweets/=1000;

   cookie/=1000;

   writeln('a)', 300 * sweets + 400 * cookie:0:4);

   writeln('б)', 3 * 1000 * sweets + 3 * 2000 * cookie:0:4);

end.

(34 баллов)