Есть три любых числа, можете взять любые. Напишите программу для Паскаля, которая выведет...

0 голосов
18 просмотров

Есть три любых числа, можете взять любые. Напишите программу для Паскаля, которая выведет количество чисел, кратных 5. (Упоминается, что можно ввести ещё одну переменную для решения;) Спасибо!


Информатика (39 баллов) | 18 просмотров
0

Мы можем взять любые... но откуда? Ввод с клавиатуры?

0

По заданию не даётся значения, нужно выбрать их самому.

0

ну ответ дан с учетом того, что 3 числа вводятся с клавиатуры

Дан 1 ответ
0 голосов

program n_1;

var a, b, c: int64;

begin

read(a, b, c);

if a mod 5 = 0 then a:=1 else a:=0;

if b mod 5 = 0 then b:=1 else b:=0;

if c mod 5 = 0 then c:=1 else c:=0;

writeln(a+b+c);

end.

Дополнительных переменных не использовано.

(3.5k баллов)