Может кто написать программу для решения ** паскале? ​

0 голосов
48 просмотров

Может кто написать программу для решения на паскале? ​


image

Информатика (12 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

(На фото всё более понятно и в цвете)


Пояснение:

1)вводится переменная n. nдолжна быть четной. Чтобы n не была введена не четной используется repeat для запроса n, пока она не будет введена чётной.

2)идёт цикл от 1 до n. Каждый раз он просит ввести a i-тое, которое каждый раз записывается по-новой в переменную g. Далее она используется для изменения значения b и c.

3)выводится ответ, где b делим на c.

b-делимое, то есть "-a1-a3-...-a(n-1)"

c-делитель, то есть "а2+а4...+аn"


Код для копирования:



program school5;

Var i, n:integer;

b, c, g:real;

begin

Repeat

Write('Введите n (n-чётное)>> ');

ReadLn(n);

Until n mod 2 = 0;

For i:=1 to n do

Begin

Write('Введите a', i, '>> ');

ReadLn(g);

If i mod 2 <> 0 then

b:=b-g

Else c:=c+g;

End;

Write('ответ: ', b/c);

end.


image
(194 баллов)
0

это все что дано

0

Подождите, попробую решить при помощи цикла.

0

спасибо, буду очень благодарен

0

Как вам удобнее получить ответ? Картинкой или текстом?

0

как вам удобнее, приму любой ответ

0

Исправил в решение

0

Пояснение не требуется?

0

спасибо, ну если не трудно то можно.

0

Сделал

0

огромное спасибо