Помогите написать программу ** языке Паскаль для нахождения среднего значения из n...

0 голосов
16 просмотров

Помогите написать программу на языке Паскаль для нахождения среднего значения из n введенных целых чисел от 10 до 100. Можете сразу вставить числа


Информатика (19 баллов) | 16 просмотров
Дано ответов: 2
0 голосов

var n,i,a,s:integer;

begin

write('n=');

readln(n);

s:=0;

writeln('Введите ',n,' целых чисел');

for i:=1 to n do

begin

 readln(a);

 if a<0 thn s:=s+a;</p>

end;

write('Сумма отрицательных=',s);

end.

(654k баллов)
0

какое-то еврейское решение)

0 голосов

var

a,b,c,d,e:integer

begin

read(n);

for c:=1 to n

begin

read(a);

b:=a+b

e:=1+e

end;

write(b/e);

end.

(70 баллов)