Написать программу и блок-схему к задаче: Дано число. Если оно отрицательное, тогда...

0 голосов
80 просмотров

Написать программу и блок-схему к задаче: Дано число. Если оно отрицательное, тогда возвести число в квадрат. а если нет - возвести в третью степень.


Информатика (12 баллов) | 80 просмотров
Дан 1 ответ
0 голосов
  1. var
  2.  N: integer;
  3. begin
  4.  Readln(N);
  5.  if N < 0 then
  6.    N := N * N
  7.  else
  8.    N := N * N * N;
  9.  Writeln(N);
  10. end.

image
(5.6k баллов)