Напишите программу ** языке Pascal. 1. Выведите первые 10 целых положительных чисел,...

0 голосов
43 просмотров

Напишите программу на языке Pascal. 1. Выведите первые 10 целых положительных чисел, которые делятся на 5 и 7 одновременно. 2. Пользователь вводит произвольную последовательность целых чисел, заканчивающуюся вводом "0". Найти среднее арифметическое среди нечетных положительных чисел последовательности. 3. Выведите таблицу стоимости товара, продаваемого на развес, начиная со 100 г и заканчивая 1.5 кг. Пользователь программы вводит стоимость одного килограмма данного товара.


Информатика (42 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

1. program ex1;

uses crt;

var i, count : integer;

begin

 count:=0;

 for i:=1 to 9999 do

 begin

   if (i mod 5 = 0) and (i mod 7 = 0) then

   begin

     writeln(i);

     count:=count+1;

     if count=10 then

       break;

   end;      

 end;

end.

2. program ex2;

var sum, count, n : integer;

begin

 count:=0;

 n:=9999;

 sum:=0;

 while not (n = 0) do

 begin

   readln(n);

   if (not n mod 2 = 0) and (n>0) then

   begin

     sum:=sum+n;

     count:=count+1;

   end;

 end;

 writeln('Ср. арифм. = ', sum/count);

end.

3. program ex1;

var price, i: integer;

begin

 write('Введите цену товара за 1 кг. :');

 readln(price);

 for i:=1 to 15 do

   write(i:6, '|');

 writeln();

 for i:=1 to 15 do

   write('-------');

 writeln();

 for i:=1 to 15 do

   write((price/10*i):6,'|');

end.

(440 баллов)