Напишите программу, которая получает ** вход три вещественных числа и находим сумму...

0 голосов
37 просмотров

Напишите программу, которая получает на вход три вещественных числа и находим сумму положительных из них. Обьясните пожалуйста каждую строку.


Информатика (107 баллов) | 37 просмотров
0

На каком языке?

0

Я не знаю какой это язык, но там используется слово if. Ток это знаю

0

writeln

0

begin

0

readln

0

И тд

0

Paskal

0

Наверное

Дан 1 ответ
0 голосов

Ну, наверное это должно выглядеть как то так. Я плохо помню паскаль

program Help;   #Заголовок

var  #Раздел с переменными

a, b ,c, summ : real;   #Входные переменные и по итогу их сумма, вещественные

begin  #Думаю понятно

   summ := 0;   #Инициализация summ, ибо статическая типизация

   writeln('Enter nums');   #Программа попросит ввести числа

   readln(a);  #Считывание

   readln(b);  #Считывание

   readln(c);  #Считывание

   

   if a > 0 then summ += a;  #Если переменная а больше нуля, прибавляем её к итоговой переменной

   if b > 0 then summ += b;  #Аналогично

   if c > 0 then summ += c;   #Аналогично

   

   write(summ);   #Выводим переменную summ на экран

       

end.

(1.6k баллов)