Напишите программу, которая получает ** вход три вещественных числа и находим сумму...

0 голосов
46 просмотров

Напишите программу, которая получает на вход три вещественных числа и находим сумму положительных из них. Язык если я не ошибаюсь называется paskal. Обьясните каждую строчку пожалуйста.


Информатика (107 баллов) | 46 просмотров
0

Что это строка обозначает? If (x>z) and (x>y) then

Дан 1 ответ
0 голосов

Var 

x,y,z:real;

begin

writeln('Введите три числа');

read(x,y,z);

If (x>z) and (x>y) then

writeln('Наибольшее= ',x);

If (y>z) and (y>x) then

writeln('Наибольшее= ',y);

If (z>x) and (z>y) then

writeln('Наибольшее= ',z);

If (z=y) and (y=x) then writeln('Все числа одинаковые') else

begin

If (z=x)  then writeln('числа x и z равны');

If (y=x)  then writeln('числа x и y равны');

If (z=y)  then writeln('числа y и z равны');

end.

end.

(14 баллов)
0

Что это строка обозначает? If (x>z) and (x>y) then