Решите пожалуйста задачу по информатике, очень нужно) Задача номер 13. в гимназии...

0 голосов
26 просмотров

Решите пожалуйста задачу по информатике, очень нужно) Задача номер 13. в гимназии необходимо покрасить пять кабинетов. известно, что длина одного кабинета равна a метров, ширина b метров, высота c в квадрате метров. на 1 метр квадратный расходуется d литров краски. напишите программу,которая поможет расчитать количество краски, которое необходимо приобрести, чтобы покрасить эти кабинеты


image

Информатика (16 баллов) | 26 просмотров
0

На каком языке программирования написать?

Дан 1 ответ
0 голосов

Если покрасить надо весь кабинет (потолок, пол и стены)

Если на Pascal:

var a, b, c, d, e, f, s: integer;

begin

readln(a);

readln(b);

readln(c);

readln(d);

s:=2*(a*b)+2*(a*c)+2*(b*c);

e:=s*d;

f:=5*e;

writeln(f);

end.

Если на Python:

import sys

a=int(sys.stdin.readline())

b=int(sys.stdin.readline())

c=int(sys.stdin.readline())

d=int(sys.stdin.readline())

s=2*(a*b)+2*(a*c)+2*(b*c)

e=s*d

f=5*e

print(f)

(106 баллов)