Написать программу p=a×b

0 голосов
25 просмотров

Написать программу p=a×b


Информатика (12 баллов) | 25 просмотров
0

а на каком языке програмирования то

Дано ответов: 2
0 голосов

program eee;

var

p,a,b: integer;

begin

readln(a,b);

p:=0;

begin

while a>0 do begin

p:=p+b;

a:=a-1;

end;

writeln(p);

end;

end.

(26 баллов)
0

Просто привычка

0

Зачем обнулять переменную если она итак изначально равна нулю ?

0 голосов

Если PascalABC то вот:

var a,b,p:real;

begin

Writeln('Введите число a,b');

readln(a,b);

p:=(a*b);

Writeln('p = ', p);

end.

(32 баллов)