Написать программу решения задачи в Pascal ABC. Задача: Занятия в школе начинаются в...

0 голосов
61 просмотров

Написать программу решения задачи в Pascal ABC. Задача: Занятия в школе начинаются в 8:30. Урок длится 40 минут, перерывы между уроками – 15 минут. Ввести номер урока и вывести время его окончания. (при решении используйте div и mod).


Информатика (42 баллов) | 61 просмотров
Дан 1 ответ
0 голосов

var n,du,dp,tn,tk,h,m:integer;

begin

writeln(' ');

repeat

write('Введите номер урока от 1 до 6 n=');

readln(n);

until n in [1..6];

tn:=480+30; (*начало занятий*)

du:=45; (*длина урока*)

dp:=10; (*длина перерыва*)

if n=1 then tk:=tn+du (*первый урок*)

else tk:=tn+du+(n-1)*(du+dp);(*другие*)

h:=tk div 60;

m:=tk mod 60;

write(h,'-',m);

end.

(6.1k баллов)
0

это точно верно?

0

это не через div и mod

0

C делайте плизз через div и mod

0

C делайте плизз через div и mod

0

C делайте плизз через div и mod

0

C делайте плизз через div и mod

0

внизу див и мод стоит

0

нету вродь

0

а всё спасибо большое

0

с конца 3 и 4 строчка