Напишите программу, которая находит среднее из трёх введённых чисел. Предполагается, что...

0 голосов
208 просмотров

Напишите программу, которая находит среднее из трёх введённых чисел. Предполагается, что все три числа различные.


Информатика (236 баллов) | 208 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var a,b,c,max,min,s: integer;

begin

readln(a,b,c);

if a>b then max:=a else max:=b;

if c>max then max:=c;

if a if c s:=(a+b+c)-(max+min);

writeln(s);

end.

Пример:

5 2 9

5

(194k баллов)