РЕБЯТ, СРОЧНО, ПОМОГИТЕ С ИНФОРМАТИКОЙ( два номера)!!Напишите программу, которая...

0 голосов
32 просмотров

РЕБЯТ, СРОЧНО, ПОМОГИТЕ С ИНФОРМАТИКОЙ( два номера)!!Напишите программу, которая определяет попадает ли точка с вводимыми с клавиатуры координатами, в заданную область(окружность). см припрепленный файл.И вторая задача: напишите программу, которая определяет попадает ли точка в заданную область(см файл) ОЧЕНЬ СРОЧНО!!!!


image

Информатика (22 баллов) | 32 просмотров
Дан 1 ответ
0 голосов

Язык СИ:

1.

#include

#include

int main(){

   

   long double x,y;

   scanf("%Lf%Lf",&x,&y);

   

   printf("%s\n",sqrtl(x*x+y*y)<=2?"yes":"no");</p>

   

   return 0;

   

}

2.

#include

#include

int main(){

   

   long double x,y;

   scanf("%Lf%Lf",&x,&y);

   

   printf("%s\n",-2<=x && x<=0 && -2<=y && y<=0?"yes":"no");</p>

   

   return 0;

   

}

(851 баллов)