Массив. Напишите программу, которая при введении «0» будет выводить «конец программы».

0 голосов
68 просмотров

Массив. Напишите программу, которая при введении «0» будет выводить «конец программы».


Информатика (32 баллов) | 68 просмотров
0

какой яп

0

Паскаль

0

При введении в массив?

0

Да

Дано ответов: 2
0 голосов

var

a:integer;

begin readln(a);

if a=0 then

writeln ("End program");

end.

(242 баллов)
0 голосов

Program asdf;

Label 1;

var

x, n: integer;

a: array [1..100] of real;

begin

n:=100;

//макс. Кол-во элементов массива

for x:= 1 to n do

begin

readln (a[x]);

if a[x] = 0 then

begin

writeln ('конец программы');

Goto 1;

end;

end;

1:

end.

(1.7k баллов)