1. Запиши ** Паскале: к целочисленному типу данных относят...

0 голосов
55 просмотров

1. Запиши на Паскале: к целочисленному типу данных относят тип____________________________Тип переменных REAL - это____________Раздел VAR служит____________________Вывод данных на экран осуществляется с помощью оператора2. Дано целое трёхзначное число а.(а) По заданному алгоритму составьте код программы.Алг Сумма. __________________Нач. __________________Вывод (х). __________________ 10+2ху= --------- __________ 11-хВывод (у). __________________кон. __________________2(б) Входные данные х = 3 определите выходные данные________3. Составьте программу для вывода на экран произведения 3 чисел.4. на фото.определите результат выполнения алгоритма___________5. Запишите код программы для заданного алгоритма.Алг Пример. ____________________Нач. ____________________х=8. ____________________у=2. ____________________если (х (больше) у) то z=x-y иначе z=x+y Вывод (х)кон. Это первая часть так как есть ещё одна сторона. Решите пожалуйста очень нужно у меня все плохо с информатикой. т.тзавтра СОЧ ​


image

Информатика (36 баллов) | 55 просмотров
Дан 1 ответ
0 голосов

Задание 1

  1. integer
  2. Вещественные числа
  3. Для объявления переменных
  4. Writeln

Задание 2

На третьей строчке, видимо, ошибка, и вместо Вывод(x) на самом деле Ввод(x).

  1. var
  2.  x: integer;
  3.  y: real;
  4. begin
  5.  Readln(x);
  6.  y := (10 + 2 * x) / (11 - x);
  7.  Writeln(y);
  8. end.

При x = 3 переменная y = 2

Задание 3

  1. var
  2.  number, resultNumber, i: integer;
  3. begin
  4.  resultNumber := 1;
  5.  for i := 1 to 3 do
  6.    begin
  7.      Readln(number);
  8.      resultNumber := resultNumber * number;
  9.    end;
  10.  Writeln(resultNumber);
  11. end.

Задание 4

  1. var
  2.  a: integer;
  3.  b, c: real;
  4. begin
  5.  a := 3;
  6.  b := -1.5;
  7.  c := 6 - 2 * b;
  8.  c := c - a;
  9.  Writeln(c);
  10. end.

Результатом вывода будет число 6

Задание 5

  1. var
  2.  x, y, z: integer;
  3. begin
  4.  x := 8;
  5.  y := 2;
  6.  if (x > y) then
  7.    z := x - y
  8.  else
  9.    z := y + x;
  10.  Writeln(z);
  11. end.
(5.6k баллов)
0

СПАСИБО БОЛЬШОЕ ТЕБЕ, ТЫ ЛУЧШИЙ О ГОСПОДИ СПАСИБО

0

Пожалуйста.