Напишите программу, которая размещает случайным образом две ладьи ** шахматной доске и...

0 голосов
341 просмотров

Напишите программу, которая размещает случайным образом две ладьи на шахматной доске и определяет, бьют ли эти ладьи друг друга.


Информатика (561 баллов) | 341 просмотров
Дан 1 ответ
0 голосов

Язык СИ:

#include

#include

#include

#include

int main(){

   

   srand(time(0));

   const long double cbc=64.0L-FLT_EPSILON;

   unsigned short int r1=cbc/RAND_MAX*rand(),

                                  r2=cbc/RAND_MAX*rand();

   

   printf("R1: %c%c\n",65+r1%8,49+r1/8);

   printf("R2: %c%c\n",65+r2%8,49+r2/8);

   printf("%s\n",r1%8==r2%8 || r1/8==r2/8?"yes":"no");

   

   return 0;

   

}

(851 баллов)