Помогите написать программу ** языке С++. Во вложениях есть условие и код, который...

0 голосов
67 просмотров

Помогите написать программу на языке С++. Во вложениях есть условие и код, который работает через раз. Спасибо!)


image
Скачать вложение Текст (TXT)

Информатика (427 баллов) | 67 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include

using namespace std;

int main()

{

setlocale(LC_ALL, "rus");

char c;

cout << "для выбора языка введи букву <e> или "

cin >> c;

int t;

cout

cin >> t;

if (c == 'e')

{

 switch (t){

 case 1: cout

 case 2: cout

 case 3: cout

 case 4: cout << "septeber, october, november" << endl; </p>

break;

 }

}

else if (c=='r')

 switch (t){

 case 1: cout

 case 2: cout

 case 3: cout

 case 4: cout

 }

}

(194k баллов)
0

Могу, но нет желания.

0

А желания писать return тоже нет?)

0

А что с неймингом переменных, DOS много сьел на винте?)

0

Писать длинее и понятнее не судьба?)

0

Не слышали о том, что литерал должен быть слева в сравнении?)

0

Просто интересно - не слыхали что код может не компилиться, если нет в switch необходимого case? А ещё как же вы хендлите если у вас не правильно введенное число?)

0

Не хотите вынести буквы r и e что являются ключами в отдельные переменные char, что бы если что их значение не менять во всех местах? (:

0

Не смущает что такая куча cout?Не хотите выводить одну переменную вместо постоянной копипасты cout? Это же не консистентно

0

А ещё знаете что забавно, у вас программа не работает если я введу не 1 букву а к примеру две...Интересно вы знаете почему?) И если да, почему не предусмотреть такой елементарный хендлинг input?)

0

Благодарю за подробный анализ программы.