Пожалуйста, помогите с информатикой, срочно! Напишите программу для Pascal, которая...

0 голосов
228 просмотров

Пожалуйста, помогите с информатикой, срочно! Напишите программу для Pascal, которая считывает одно натуральное число и выводит на первой строке все делители этого числа в порядке возрастания, разделённые пробелами, а на второй — «ПРОСТОЕ» или «НЕТ» в зависимости от того, простым было введённое число или нет.Формат вводаОдно натуральное число.Формат выводаВ первой строке — все делители введенного числа, записанные через пробел (перед первым и после последнего делителя пробелов нет). Во второй — сообщение «ПРОСТОЕ» или «НЕТ».Пример: Ввод:12 Вывод:1 2 3 4 6 12НЕТ​


Информатика (40 баллов) | 228 просмотров
Дан 1 ответ
0 голосов

Program n_1;

var x, i, k:int64;

begin

   readln(x);

   k:=0;

   for i:=1 to x do

       if x mod i = 0 then begin

           write(i, ' ');

           k:=k+1;

       end;

   writeln();

   if k>2 then writeln('НЕТ')

   else writeln('ПРОСТОЕ');

end.

(3.5k баллов)