Помогите написать программу в С++. со всеми библиотеками и со всем остальным

0 голосов
43 просмотров

Помогите написать программу в С++. со всеми библиотеками и со всем остальным


image
image

Информатика (18 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

1.

#include

#include

using namespace std;

int main(){

double x = 0.4 * pow(10, 4);

double y = -0.875;

double z = abs(cos(x) - cos(y));

z *= (1 + y + (pow(y, 2)/2) + (pow(y, 3)/3) + (pow(y, 4)/4));

cout << z;</p>

return 0;

}

2.

#include

#include

using namespace std;

int main(){

double a = -0.5;

double b = 1.7;

double t = 0.44;

double y = exp(-b*t) * sin(a*t+b);

y -= sqrt( abs(b*t + a) );

double s = b * sin(a*t*t * cos(2*t));

cout << "y: " << y << endl;</p>

cout << "s: " << s;</p>

return 0;

}

(162 баллов)
0

огромное спасибо, все работает

0

1. Почему глобально пользуем namespace?

0

2. Почему переменные x,y,z не константные?

0

А вообще почему не constexpr?

0

Те же вопросы ко второму ответу тоже.

0

Просто если не умеешь писать на плюсах или си, не пиши пожалуйста, тут уже есть люди (я не про себя), которые пишут код с quality чуть по выше)