Написать программу ** паскале. Заполнить массив: двадцатью первыми натуральными числами,...

0 голосов
121 просмотров

Написать программу на паскале. Заполнить массив: двадцатью первыми натуральными числами, делящимися нацело на 13 или на 17 и большими 300 Пожалуйста! Очень надо!!!!!!!!!!


Информатика (16 баллов) | 121 просмотров
Дан 1 ответ
0 голосов

var a:array [1..20] of integer;

i,k:integer;

BEGIN

k:=301;

for i:=1 to 20 do begin

while (k mod 17<>0) and (k mod 13<>0) do

k:=k+1;

a[i]:=k;

k:=k+1;

end;

for i:=1 to 20 do

write(a[i],' ');

end.

(1.4k баллов)