Помогите с паскалем Программирование алгоритмов с циклами (с заранее известным числом повторений) при работе с одномерными массивами 4 .Написать программу для нахождения значения переменной S по формуле:
var p,i, n: integer; s: real;
readln(n);
p:=1;
for i:=2 to n do
begin
p:=p*i;
end;
s:=ln(p);
writeln(s);
end.
Вводим n и вычисляем с помощью цикла for сумму натуральных логарифмов