Написать программу обработки двумерного массива: дан массив А 15 строк и 15 столбцов....

0 голосов
29 просмотров

Написать программу обработки двумерного массива: дан массив А 15 строк и 15 столбцов. Заполнить массив случайными числами, найти мах, мин, и сумму элементов всего массива
Нужно в тетраде написать
Нужно написать так,как в паскале


Информатика (17 баллов) | 29 просмотров
Дан 1 ответ
0 голосов
var a, b, c, d, i, j :integer;
     s :array [1..100,1..100] of integer;
begin
   b:=63999;
   c:=-63999;
   for i:=1 to 15 do
      begin
      writeln;
      for j:=1 to 15 do
         begin
         s[i,j]:=random(127998)-63999;
         a:=a+s[i,j];
         if s[i,j]>c then c:=s[i,j];
         if s[i,j]
         write (s[i,j],' ');
         end;
      end;
   writeln;
   writeln ('Сумма элементов = ', a);
   writeln ('Максимальный элемент = ', c);
   writeln ('Минимальный элемент = ', b);
end.
(1.9k баллов)