Даю 35 баллов !!!!Написать программу ** языке программирования в паскале:Найти все целые...

0 голосов
53 просмотров

Даю 35 баллов !!!!Написать программу на языке программирования в паскале:Найти все целые числа из промежутка от 100 до 300, у которых сумма делителей равна K?(K вводится с клавиатуры)​


Информатика (12 баллов) | 53 просмотров
Дан 1 ответ
0 голосов

var i,k,j,s:integer;

begin

  readln(k);

  FOR I:=100 TO 300 DO

  begin

     s:=0;

     for j:=1 to i do

     if i mod j=0 then s:=s+j;

     if s=k then writeln(i);

 end;

end.

(192 баллов)