Помогите написать программу ** паскале!!!!!!!!!!!!!!!!!!!!!!!!! Дана прямоугольная...

0 голосов
29 просмотров

Помогите написать программу на паскале!!!!!!!!!!!!!!!!!!!!!!!!! Дана прямоугольная матрица размером . Определить номер строки, сумма элементов которой максимальна, и поменять местами эту строку и последнюю строку матрицы. Если данная строка оказалась последней, выдать на экран сообщение, о том, что менять строки местами не нужно.


Информатика (12 баллов) | 29 просмотров
Дан 1 ответ
0 голосов

На входе вводим с клавиатуры размерность массива: n строк и m столбцов.

Первые два вложенных цикла - это ввод двумерного массива с помощью датчика случайных чисел randomize.

Далее во вложенных циклах ищем максимальную сумму элементов по строкам и запоминаем номер строки в переменную k.

Строку с выводом s и k писать не нужно.

Далее один цикл обмена к-той строки и последней.

Последние вложенные циклы выводят изменённый массив.

Прежде чем выводить массив нужно поставить поверку:

If k=m then write(‘Менять строки местами не нужно’) else begin и последние два вложенных цикла.


image
(192 баллов)