Напишите программу,в которой вводятся четыре числа ( длины четырёх отрезков ). Выведите...

0 голосов
75 просмотров

Напишите программу,в которой вводятся четыре числа ( длины четырёх отрезков ). Выведите "Да" если из отрезков можно составить прямоугольник инче выведите "Нет"


Информатика (12 баллов) | 75 просмотров
Дан 1 ответ
0 голосов

program ugol;

var a,b,c,f:integer;

begin

writeln('Введите шширину');

readln(a);

readln(b);

writeln('Введите длину');

readln(c);

readln(f);

if (a<>b) or(c<>f)then

writeln('Нет')

else

if (a=b)and(c=f) then

writeln('Да');

end.

(Исправленая версия)

ps(затупил подумал что квадрат это прямоугольник)

(190 баллов)