СРОЧНО, ИНФОРМАТИКА!ПАСКАЛЬ, 8 КЛАСС. Нужно составить программу,которая запрашивает целое...

0 голосов
28 просмотров

СРОЧНО, ИНФОРМАТИКА!ПАСКАЛЬ, 8 КЛАСС. Нужно составить программу,которая запрашивает целое число А < 5 и находит наименьшее натуральное n, при котором A^n >= 50. n вывести на экран. ​


Информатика (62 баллов) | 28 просмотров
0

А число "A" больше нуля?

0

Да

Дан 1 ответ
0 голосов

var A,i:integer;

BEGIN

readln(A);

for i:=13 to 50 do

if (A*i>=50) then begin

writeln(i);

break;

end;

end.

(1.4k баллов)
0

можно задать вопрос? почему от 13 до 50 ?