Написать программу определения стоимости разговора по телефону с учетом скидки 20%...

0 голосов
144 просмотров

Написать программу определения стоимости разговора по телефону с учетом скидки 20% представляемой по субботам и воскресениям.
Вид экрана:
вычисление стоимости разговора по телефону (2р. - 1мин)
введите исходные данные
длительность разговора (целое число минут) 3
день недели ( 1-пон .... 7-воскр)? 6
предостовляется скидка 20%
стоимость разговора 4.80р


Информатика (19 баллов) | 144 просмотров
0

??

0

сначала вводится число минут потом день недели учитывая скидки в субботу и в воскресенье а потом выводит стоимость разговора если 1 мин разговора 2р а 4,8р здесь зачем?

Дан 1 ответ
0 голосов

Program gt;
var n,a:integer;
s:real;
begin
readln(n);
readln(a);
case a of
1..5:
s:=n*2;
6:
s:=10.4;
7:
s:=10.8;
end;
writeln(s);
end.

n-число минут
a-день недели
если case не проходили то можно сделать if
program gt;
var n,a:integer;
s:real;
begin
readln(n);
readln(a);
if(a<6)then s:=n*2;<br>if(a=6)then s:=10.4;
if(a=7)then s:=10.8;
writeln(s);
end.

(6.6k баллов)