Напишите программу Найти значение y, если х - вещественное число. y=-5+3x, если х>0, либо y=x2-2, в противном случае.
var x,y: integer;
begin
readln (x);
if x>0 then y=-5+3*x else
y=2*x-2
writeln (x);
end.
написал примерно, но должно работать.