Напишите программу в паскале для решения квадратных уравнений ​

0 голосов
25 просмотров

Напишите программу в паскале для решения квадратных уравнений ​


Информатика (38 баллов) | 25 просмотров
Дан 1 ответ
0 голосов

procedure solution(k,y,z : real);

var

D,x1,x,x2:real;

begin

D:=y*y-4*k*z;

if D>0 then

 begin

   x1:=(-y+sqrt(D))/2*k;

   x2:=(-y-sqrt(D))/2*k;

   writeln('x1=',x1);

   writeln('x2=',x2);

 end

else if D=0 then

 begin

   x:=-1y/2*k;

   writeln('x=',x);

 end

else

 writeln('Нет вещественных корней');

end;  

var

a,b,c :real;

begin

writeln('Введите коэфиценты a,b,c');

read(a,b,c);

solution(a,b,c);

end.

(12.2k баллов)