Помогите пожалуйста написать программы в PascalABC 1. Даны два числа. Удвойте большее...

0 голосов
18 просмотров

Помогите пожалуйста написать программы в PascalABC 1. Даны два числа. Удвойте большее число, утройте меньшее число. 2. У Васи было 300 рублей. Он решил купить несколько шоколадных батончиков по некоторой цене. Хватит ли у него денег? Напишите программу, которая запрашивает количество батончиков и цену батончиков. В результате должен появиться ответ "хватит денег" или "не хватит денег" и сколько денег останется в случае, если денег хватит. Если же денег не хватит, то вывести, какой суммы не достает.


Информатика (42 баллов) | 18 просмотров
Дан 1 ответ
0 голосов

Ответ:

Объяснение:

1.

var a, b: integer;

begin

read(a, b);

if a < b then

begin

a := a * 3;

b := b * a

end

else

begin

a := a * 2;

b := b * 3;

end;

print(a, b);

end.

2.

var kol, cen: integer;

begin

writeln('Введите количество и цену');

read(kol, cen);

if kol * cen < 300 then writeln('Хватит денег')

else writeln('Не хватит ', kol*cen - 300, ' рублей.')

end.

(313 баллов)