Напишите программу, которая выводит ** экран таблицу умножения ** n ( n-целое число в...

0 голосов
646 просмотров

Напишите программу, которая выводит на экран таблицу умножения на n ( n-целое число в диапазоне от 2 до 10, вводимое с клавиатуры), Паскаль.


Информатика (99 баллов) | 646 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Вариант с проверкой правильности ввода

var
    n, i: integer;

begin
    n := 0;
    while (n <= 1) or (n > 10) do
    begin
        write('Введите n в диапазоне от 2 до 10 = ');
        readln(n);
    end;
   
    for i := 1 to 9 do
        writeln(n, ' * ', i, ' = ', n * i);
end.

без проверки

var
    n, i: integer;

begin
    write('Введите n в диапазоне от 2 до 10 = ');
    readln(n);
   
    for i := 1 to 9 do
        writeln(n, ' * ', i, ' = ', n * i);
end.

(55.0k баллов)