Помогите пожалуйста написать программу (в паскаль) , которая вводит число и выводит ее...

0 голосов
35 просмотров

Помогите пожалуйста написать программу (в паскаль) , которая вводит число и выводит ее половину, четверть, одну восьмую, одну шестнадцатую.​


Информатика (29 баллов) | 35 просмотров
Дан 1 ответ
0 голосов

1 Вариант без использования цикла

program delenie1;

var a:real;

begin

write('Введите число: ');

readln(a);

writeln('Половина: ', a/2);

writeln('Четверть: ', a/4);

writeln('Одна восьмая: ', a/8);

writeln('Одна шестнадцатая: ', a/16);

end.

2 Вариант с использованием цикла

program delenie2;

var a:real;

i:integer;

begin;

write('Введите число: ');

readln(a);

for i:=1 to 4 do

 begin

 a:= a/2;

 writeln(a);

 end;

end.

(2.1k баллов)