Написать программу для решения задач(Паскаль):1)Вычислите значения выражения 2)Насти...

0 голосов
14 просмотров

Написать программу для решения задач(Паскаль):
1)Вычислите значения выражения \frac{b+ \sqrt{ b^{2}+4ac} }{2a} +IbI
2)Насти среднее арифметическое четырех чисел.


Информатика (126 баллов) | 14 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program gt;
var a,b,c,y:real;
begin
readln(a,b,c);
if(b*b+4*a*c<0)then writeln('это невозможно')else begin<br>y:=(b+sqrt(b*b+4*a*c))/(2*a)+abs(B);
writeln(y);
end;
end.
2)
program gt2;
var a,b,c,d,e:real;
begin
readln(a,b,c,d);
e:=(a+b+c+d)/4;
writeln(E);
end.

(6.6k баллов)