Помогите, пожалуйста!1. Написать программу которая ищет n! (цикл while)2. Написать...

0 голосов
99 просмотров

Помогите, пожалуйста!1. Написать программу которая ищет n! (цикл while)2. Написать программу, которая находит число Р = (1-1/2)(1-1/3)*...*(1-1/n). N вводится с клавиатуры. (цикл for)


Информатика (12 баллов) | 99 просмотров
Дан 1 ответ
0 голосов

Ответ:

Объяснение:

1.

var

 k:integer;

 p:integer;

 n:integer;

begin

 readln(n);

 

 p:=1;

 k:=1;

 

 while (k

   p:=p*k;

   k:=k+1;

 end;

 

 writeln(p);

 

end.

2.

var

 k:integer;

 p:real;

 n:integer;

begin

 readln(n);

 

 p:=1;

 

 for k:=2 to n do begin

   p:=p*(1 - (1/k));

 end;

 

 writeln(p);

 

end.

(3.1k баллов)