Напишите программу, которая получает ** вход строку типа "Иван Иванович Иванов"(ИОФ), а...

0 голосов
106 просмотров

Напишите программу, которая получает на вход строку типа "Иван Иванович Иванов"(ИОФ), а выводит строку типа "Иванов Иван Иванович"(ФИО)


Информатика (97 баллов) | 106 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Ответ:

как то так чтоль

var f,i,o,iof:string;

c,probel:integer;

begin

readln(iof);

probel:=0;

for c:=1 to length(iof) do begin

if (iof[c]<>' ') and (probel=0) then i:=i+iof[c];

if (iof[c]<>' ') and (probel=1) then o:=o+iof[c];

if (iof[c]<>' ') and (probel=2) then f:=f+iof[c];

if iof[c]=' ' then inc(probel);

end;

writeln(f,' ',i,' ',o);

end.

Объяснение:

(134 баллов)