Ребят, помогите пожалуйста!!! Сижу, ломаю голову над заданием по информатике. Суть задачи...

0 голосов
39 просмотров

Ребят, помогите пожалуйста!!! Сижу, ломаю голову над заданием по информатике. Суть задачи такова: " составить программу по нахождению заштрихованной области на языке Паскаль(язык программирования), но при этом компьютер должен сам придумать числа через randomize ( для буквенных обозначений в формуле).​


image

Информатика (12 баллов) | 39 просмотров
0

Нужно найти площадь заштрихованной области?

0

да

Дан 1 ответ
0 голосов

begin

randomize;

a:= random(40,50);

b:= random(20,30);

a1:= random(20,25);

b1:= random(10,15);

writeln('Длины сторон дачного участка:');

writeln('Длина: ',a,' м');

writeln('Ширина: ',b,' м');

writeln;

writeln('Длины сторон дома:');

writeln('Длина: ',a1,' м');

writeln('Ширина: ',b1,' м');

writeln;

c:= a*b-a1*b1;

writeln('Площадь свободного участка: ',c,' м²');

end.

Программа написана на языке PascalABC.NET

(2.1k баллов)
0

пару сек) я проверю быстро