Написать программу ** Паскале, используя цикл: 1) Посчитать сумму четных чисел, меньших...

0 голосов
53 просмотров

Написать программу на Паскале, используя цикл: 1) Посчитать сумму четных чисел, меньших или равных n S = 2 + 4 + 6 + … + n 2. Найти сумму нечётных цифр числа 3. Возвести число в степень.


Информатика (12 баллов) | 53 просмотров
Дан 1 ответ
0 голосов

Ответ:

Объяснение:

// Возведение в степень

program stepen;

var

p,i,n, a:integer;

begin

write('введите число и степень');

readln(a,n);

p:=1;

for i:=1 to n do p:=p*a;

writeln('Число ',a, ' в степени ',n,' = ',p);

readln;

end.

//Сумма нечетных цифр числа

program project1;

var

a, b, s : integer;

begin

s := 0;

write('введите число: ');

readln(a);

while a <> 0 do

begin

b := a mod 10;

if b mod 2 <> 0 then s := s + b;

a := a div 10

end;

writeln('сумма нечетных цифр: ', s);

readln;

end.  

//Сумма четных чисел до n

program summach;

var

S,n,i:integer;

begin

Write('Введите n=');

readln(n);

if n mod 2<>0 then n:=n-1;

n:=n div 2;

s:=0;

for i:=1 to n do

s:=s+2*i;

writeln('s=',s);

readln;

end.    

//===================================

//   сумма четных с циклом repeat

program summach1;

Write('Введите n=');

readln(n);

if n mod 2<>0 then n:=n-1;

s:=0;i:=1;

repeat

s:=s+2*i;

i:=i+1;

until 2*i>n ;

writeln('n=',n);

writeln('s=',s);

readln;            

(3.3k баллов)