Pascal написать программу, для подсчета площади и периметра прямоугольника, если заданы...

0 голосов
69 просмотров

Pascal написать программу, для подсчета площади и периметра прямоугольника, если заданы стороны прямоугольника ( сделайте пожалуйста готовое, я не могу понять что как куда вставлять)


Информатика (64 баллов) | 69 просмотров
Дан 1 ответ
0 голосов

var

 a, b, s, p: real;

begin

 writeln('Введите длину прямоугольника:');

 read(a);

 writeln('Введите ширину прямоугольника:');

 read(b);

 s := a * b;

 p := 2 * (a + b);

 writeln('Площадь прямоугольника = ', p, #10, 'Периметр прямоугольника = ', s);

end.

(3.7k баллов)
0

я не шарю в программировании

0

какие ошибки?

0

var  a, b, s, p: real;begin  writeln('12');  read(a);  writeln('4');  read(b);  s := a * b;  p := 2 * (a + b);  writeln('48', p, #10, '96 ', s);end

0

что не так?

0

а что это?)

0

это то, что я вбила в паскаль

0

мой алгоритм

0

там есть что-то неправильное?

0

что-то нужно дополнить*

0

я же добавил нормальный ответ, в нем все правильно...