Написать программу ** вход которой подается 2 числа найти их произведение не используя...

0 голосов
26 просмотров

Написать программу на вход которой подается 2 числа найти их произведение не используя умножение блок схема


Информатика (126 баллов) | 26 просмотров
Дан 1 ответ
0 голосов

Ответ:

import java.io.BufferedReader;

import java.io.InputStreamReader;

public class NewClass {

   public static void main(String[] args) throws Exception {

   BufferedReader reader = new BufferedReader(new InputStreamReader(System.in)); //поток ввода данных

   int a = Integer.parseInt(reader.readLine()); //вводим первое число

   int b = Integer.parseInt(reader.readLine()); //вводим второе число

   int result = b; //результат

   //здесь цикл сложения второго числа

       for (int i = 1; i < a; i++) {

           result += b;

       }

       //выводим результат в консоль

       System.out.println("Ваш ответ: " + result);

       reader.close();

   }

}

Объяснение:

написано на Java, не уточнили на каком ЯП надо программу написать..

(62 баллов)