Помогите написать программу в паскале , которая вычесляет y=2x+3x2+4x3+...+10x11

0 голосов
45 просмотров

Помогите написать программу в паскале , которая вычесляет y=2x+3x2+4x3+...+10x11


Информатика (12 баллов) | 45 просмотров
Дан 1 ответ
0 голосов

Ответ:

Объяснение:

Смущает последнее слагаемое, выбивается из закономерности.

должно быть 11х¹⁰ или 10х⁹

program sumxproj;

uses math;

var

x,Y:real;

n,i:integer;

begin

Write('Введите x=');

readln(x);

n:=10;

Y:=0;

for i:=1 to n do

Y:=Y+(i+1)*power(x,i);

writeln('Y=',Y:6:2);

readln;

end.          

(3.3k баллов)